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No part of this document may be used for any purpose other than for 
the purposes specifically indicated herein nor may it be reproduced or 
transmitted in any form or by any means, electronic or mechanical, 
including photocopying and/or recording, for any purpose without 
written permission from Unitronics. 

The information appearing in this document is for general purposes 
only. Unitronics makes no warranty of any kind with regard to the 
information appearing in this document, including, but not limited to, 
implied warranties of merchantability and/or fitness for a particular 
use or purpose. Unitronics assumes no responsibility for the results, 
direct and/or indirect, of any misuse of the information appearing in 
this document nor for any use of the Unitronics products referred to 
herein in any manner deviating from the recommendations made in 
this document. Unitronics assumes no responsibility for the use of 
any parts, components, or other ancillary appliances including 
circuitry other than as recommended hereunder or other than that 
embodied in the Unitronics product. 

Unitronics retains all rights to its proprietary assets including, but not 
limited to its software products which are copyrighted and shall 
remain the property of Unitronics. Copyright protection claimed 
includes all Forms and matters of copyrightable materials and 
information legally allowed including but not limited to material 
generated from the software programs which are displayed on the 
screen of the Unitronics products such as styles, templates, icons, 
screen displays, looks, etc. Duplication and/or any unauthorized use 
thereof are strictly prohibited without prior written permission from 
Unitronics. 

All brand or product names are used for identification purpose only 
and may be trademarks or registered trademarks of their respective 
holders. 

Unitronics reserves the right to revise this publication from time to 
time and to amend its contents and related hardware and software at 
any time. Technical updates (if any) may be included in subsequent 
editions (if any). 
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DataXport 
DataXport creates logs of run-time or stored data from Data Tables and operand regions 
within Unitronics PLCs.  DataXport saves the data logs in .ulp format. You can open these 
data logs using DataXport's companion application, DataXls, and then export the data to 
Excel files. 

Via DataXport, you can: 

� Log data according to a date/time-based schedule.  
� Simultaneously log data from one or more Unitronics PLCs. 
� Access PLCs and log data via a direct, network, Ethernet, or modem 

connection. 
� Save the data that is logged during each session to an Excel file, and 

automatically email it at the end of a session.  

Building a DataXport Project 
Start DataXport:   

1. Go to Start > Programs > Unitronics> DataXport.  
-or-  
Open the Unitronics folder located on the Desktop, then double-click on the DataXport 
icon.  Note that DataXport is installed in the Unitronics program group by default. It is 
stored elsewhere only if you specified another program group during installation.  

2. The DataXport design window opens.  

The DataXport Design window displays the list of Site you include in the project, together 
with the parameters of how the PLC within the Site is accessed. 
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To build a DataXport 
project, you first define the 
project's modules listed on 
the right. These modules 
determine when the data is 
logged, which data is 
logged, and how the PLC 
can be accessed.   

Once their parameters are 
defined, all of these 
modules are global to the 
entire DataXport project 
and may be linked to any 
PLC in the Site List. 

The Site List comprises all 
of the PLCs in the project 
together with all of the 
linked parameters. 

Module 1: Schedules - When to Log 
The Schedule determines the time intervals data between data log actions.  

1. Select Schedules from the Design menu. 

2. Click Add to create a new schedule, click Edit or double-click a line to redefine an 
existing schedule; the Schedule opens. 

3. Make the appropriate entries, then click OK to add the Schedule to the list. 
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Module 2: Tables & Regions - What to Log  
DataXport can log data either from Data Tables, an M90/91 PLC's Database, or from 
Regions of operands. 

Vision Data Tables 
To log data from PLC Data Tables within Vision PLCs, DataXport must first import Data 
Table structures from the PLC.  To do this, DataXport can access the PLC via direct 
connection, modem,  Ethernet, or CANbus/ R485. 

Check the related topic, Linking to a PLC to Import Data Tables. 

Table assigns a working name to the data that is harvested from a PLC Data Table. 

1. Select Tables from the Design menu. 

2. Click on the Import Data Table Structure button, then click Add to append it to the 
list. 

3. Name the Data Table Structure, then either: 

� Read the structure from the PLC  
-or-  

� Import a .upd file. 
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Notes • If the PC does not have a working communications link to the PLC as described 
in the topic Linking to a PLC to Import Data Tables, you will not be able to 
import Table structures..  

• If your project includes more than one PLC, and the Data Tables in these PLCs 
are identical, you do not have to import them from each PLC. Importing un-
needed Data Tables will make the project very 'heavy'. 

Once the Data Tables have been imported from the PLC, they are listed in the Data Table 
Structure left-hand pane as shown below. Highlighting one displays the Table names in 
the right hand pane.  

4. Click a Structure, select a Table within the structure, and then enter Rows to Read 
for that specific table. The Read From and Read To pointers are linked to DWs in the 
PLC. The DW values determine the length of the block of data that is collected from 
the PLC Data Table each time the site is scanned.  
You can also select the Read Entire The PLC can now read an entire table during a 
session, without using FIFO pointers. 
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M90 Database 
The M90 OPLC has a special memory area containing integers that are function as a 
database. These integers are not related in any way to system or memory integers. 
 Within the database, you can access and use integers 0 through 1023 via SI 40 and SI 
41.  

Since, unlike Vision PLCs, the M90 database is not structured, there is no structure to 
import.   

Table assigns a working name to the data that is harvested from a PLC Data Table. 

1. Select Tables from the Design menu. 

2. Click on the M90 tab. 

3. Name the Data Table Structure, enter the Start Address and other parameters; and 
then click OK; the Table is added to the list. 
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Notes • 
An Invalid FIFO pointers error results if a FIFO pointer is out of the range of 
MI addresses used for the M90 Database. 

Data Regions 
Defining regions enables you to harvest data from the operands within a PLC.  

1. Select Regions from the Design menu; the Regions window opens. 

2. Enter parameters as shown below. 
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Reading values: FIFO Pointers 
The FIFO pointers determine the size of the block of data read during a DataXport call. 

� Pointer: Read from / FIFO out (MI), incremented by DataXport. 
This MI is incremented by DataXport after each reading. It should not be 
used for any other purpose in your Ladder application.  

� Pointer: Read to / FIFO In (MI), incremented by PLC. 
This is the MI you use in your Ladder application to indicate which data is to 
be logged. It is generally the MI you use to fill the Data Table.  

� MB to set (optional): this MB is turned ON by DataXport after each reading. 
You must reset this bit in your application after each reading. 

Example 

An application stores a temperature value into a PLC Data Table every minute. Each time 
the temperature is stored into a Data Table register, MI 150 is incremented by one. The 
incrementing value enables the temperature to be stored into consecutive Data Table 
registers. Within the DataXport project, MI 150 is the Pointer: Read to / FIFO In, and MI 
100 is the Pointer: Read from / FIFO Out. 

The DataXport application is set to call the PLC and log data every 20 minutes.  

When the application starts running, both MI150 (PLC pointer) and MI100 (PC pointer) 
hold 0. MI 150 is incremented by 1 every minute, when the temperature is stored into 
the PLC.  After 20 minutes, the value of MI 150 will be 19.  

DataXport then calls the PLC. During the call, DataXport logs Data Table values from 
register 0 to 19, and then writes '19' into MI100.  The PLC application continues running; 
each minute the temperature is stored and MI 150 is incremented by 1. 

At the beginning of the next DataXport call, 20 minutes later, the value of MI 150 will be 
39, while the value of MI100 will still be 19. During the call, DataXport will log the new 
values--from 20 to 39--and will write '39' into MI 100.  

Notes • An Invalid FIFO pointers error results if a FIFO pointer is: 
� Less than 0. 
� Greater than or equal to the number of rows in the Data Table. 
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Module 3: Ports - How to Access the PLC 
Ports determine the parameters of the communication link that is used by the PC running 
DataXport in order to access a PLC and log data. 

Note • The Connection menu options are not related to the way the PC (DataXport) will 
access a PLC in order to log data. Connection menu options are only used to 
access a PLC in order to import Data Table structures from Vision PLCs. 

• The PLC name must be identical to the name assigned in the controller's 
Ladder application via Set PLC Name. 

1. Select Ports from the Design menu; the PC Ports window opens. 

2. Double-click a line to open PC Port Settings, then make the desired selections.. 

Note that the lower lines in the PC Ports windows can be configured for TAPI, and the 
last 2 lines for Ethernet. 

Ethernet Listen sets a particular PC port, via which PLCs can 'call' and connect to the PC. 
Once the connection is established, the PC will export whatever data is set for that PLC.  
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Linking PLCs to Modules: the Site List  
Once all of the modules have been defined, you can create the Site List. 

1. Select Add Site from the Design menu; the PLC window opens. 

2. In the left-hand pane, enter the PLC name, then select the module parameters 
displayed on the right-hand side of the PLC window as shown below.  

The PLC name must be identical to the name assigned in the controller's 
Ladder application via Set PLC Name. 

3. Make the appropriate selections regarding PLC type. 

4. Select a PC port, the COM ports that are offered are the ones defined in the Ports 
Module. The required parameters in this section change according to the port you 
select. For example, if you select a port connected to a modem, you fill in a phone 
number; if you select an Ethernet port, relevant parameters such as IP address are 
required.  

5. Select MB to set if you want a specific MB to turn ON when this PLC is accessed. 

6. Select Enabled if the PC is to include this specific PLC site when the DataXport 
project is run.  If Enabled is not selected, data will not be logged from this PLC even 
though it appears in the project. 

7. If the PLC is in a network, select that option and the correct Network ID. 

8. Select Excel files to cause DataXport to create an Excel file whenever a data log is 
created. Note that DataXport creates a separate Excel file for each data log.  
 

Note • If you do not select the Use Excel Template option, DataXport will use a default 
Excel template. To cause DataXport to use a customised Excel template: 
a. Select Use Excel Template. 
b. Store the template in the folder :::\\DataXport\Excel Templates. 
 
The name of the Excel template must be identical to the PLC Name given in 
the Site. 

9. In the right-hand pane, select the desired 

� Schedules, 
� Tables and/or Regions, 
� Emails 
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These are all of the parameters that have already been defined in the project. 

Note • All modules; Schedules, Ports, Tables and/or Regions; are global to the entire 
DataXport project. You can link any module to any number of Sites. 

10. When the PLC has been defined, click OK, the PLC is added to the list and will be 
displayed in the DataXport Design window. When the list is complete, save and 
name the project. 

To edit the parameters of a PLC that is already in the list, double-click the line to open it. 

 

Checking the Project 
When the project is complete, Select Check from the Actions menu to find any errors. 

After correcting any errors, you can run the project 
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Running the DataXport Project 
Run, located on the Actions menu, activates the DataXport project. 

1. Select Run from the Actions menu, DataXport begins exporting the requested data 
from Data Tables and operands within the target PLCS, via the defined ports and 
according to the defined schedules. 

Note that you can also force a call. 

You can also cause a DataXport project to enter Run Mode whenever the project is opened 
by selecting that option from the Actions menu. 
 

Force Call 
You can force the PC to call a PLC and export the data tables/regions defined for that PLC 
in one of two ways: 

� By sending an SMS message to the PC's GSM modem. Assuming that the 
name of the site is Production 1, the SMS must read  
DATAXPORT CALL TO: Production 1 
Note the capital letters and semicolon. 

� By selecting Run Project, and then clicking the Force Call button shown 
below. 
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Viewing Logs 
View, located on the Project menu, shows the DataXport log calls. To view the logged 
data, use DataXls. 

1. Select View from the Project menu, Site status is displayed. 

DataXls: Accessing Data Logs 
DataXls enables you to open the logs in Excel format. You can then manipulate the data 
in Excel. 

Start DataXls:   

1. Go to Start > Programs > Unitronics> DataXls.  
-or-  
Open the Unitronics folder located on the Desktop, then double-click on the DataXls 
icon.   

2. Click the Open icon, then navigate to the desired .ulp project and click Open.  
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DataXls opens the project as shown below. 

3. To view files in Excel, drag the mouse over a log to highlight it, then either: 
- Select the Excel icon from the toolbar,or, 
-Right-click the highlighted area and select Send Selected to Excel. 
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