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This Guide uses a concrete example to guide you through 4 start-up steps in the order given below
until you have obtained a functional application. You will then be able to traverse an axis and get to
know and try out the basic hardware and software functions of your FM 354 or FM 353. The refer-
ences to the Manual are intended to give you an initial overview of the information contained in the
Manual.

Depending on your level of experience, you will need approximately 1 1/2 to 2 1/2 hours to work
through this example.

Hardware and software requirements

The following preconditions must be fulfilled:
� You have a SIMATIC 300 station, comprising a power supply module and a CPU 31x (including a

DIN rail as subrack).
� You have an FM 354 or FM 353 module, the associated configuring package and the necessary

accessories such as bus connector, front connector and wiring material.
� You have a power section (e.g. SIMODRIVE 611-A or FM STEPDRIVE), a motor (e.g. 1FT5 or

SIMOSTEP) and the appropriate setpoint cable. The power section and motor have already been
commissioned.

� You have a rotary incremental encoder (servo drive − FM 354 only) and matching measuring sys-
tem cable.

� STEP 7 (V5.3 + SP2 or later) is installed correctly on your programming device.

Installing and wiring the FM 354 or FM 353

Insert the bus connector supplied with the FM 354 or FM 353 into the CPU bus connector. Insert the
FM 354 or FM 353 module in the DIN rail, lower it down into position and tighten the mounting screws.
For more detailed instructions, please refer to Section 3.1 of the Manual.

Wire up the front connector. Insert front connector X1 in the FM 354 or FM 353 and lock. For a de-
scription and connection instructions for front connector, please refer to Sections 4.6 and 4.7 of the
FM 354 Manual or Sections 4.4 and 4.5 of the FM 353 Manual.

Connecting up the drive:

Connect the free end of the connecting cable to the terminals of the drive unit. (The terminal designa-
tions at the ends of pre-assembled cables ordered from the catalog are labelled with the appropriate
terminals for SIMODRIVE equipment or the corresponding pin assignments for the subminiature D
socket connector (15-way) for FM STEPDRIVE). The following condition must be fulfilled on SIMO-
DRIVE equipment: CW motor rotation with positive speed setpoint. In the case of STEPDRIVE mo-
tors, a 24 V supply must be applied to input GATE_N for pulse enabling. Insert the subminiature D
socket connector (9-way or 15-way) in connector X2 on the FM 354 or FM 353. Tighten the knurled-
head screws to lock the connector in place. For a description and connection instructions for the drive,
please refer to Sections 4.2 and 4.3 of the FM 354 or FM 353 Manual.

Connecting up the encoder (servo drive − FM 354 only):

Attach the connecting cable to the encoder. Insert the subminiature D connector (15-way) in socket
X3 on the FM 354. Tighten the knurled-head screws to lock the connector in place. For a description
and connection instructions for the encoder, please refer to Sections 4.4 and 4.5 of the Manual.
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Connect the programming device to the CPU.

Switch the CPU to the STOP state.

Test: Switch on the power on the power supply module. The red LED marked “SF” on the FM then
lights up briefly and goes out again on successful completion of an internal module test. The
yellow LED marked “DIAG” on the FM lights up briefly after about 8 s and goes out at the same
time as LED “SF”.

When the connections have been made correctly, green LEDs “DC 5V” on the CPU and the FM
354 or FM 353 light up.

Installing the configuring package on the programming device

The configuring package contains the “Parameterize FM 354” or “Parameterize FM 353” tool, the
function blocks (FCs), the data structure (UDT 1), a preconfigured example interface for the OP 7/17
(irrelevant here) and user examples.

Insert the CD ROM in the CD ROM drive of your PG/PC.

Run file Setup.exe on the CD ROM.

Follow step by step the instructions displayed by the installation routine.

The software is installed in the following directories when the defaults are accepted:
� “Parameterize FM 354” or “Parameterize FM 353” parameterization tool: “Siemens\Step7\S7FLAG

or \S7FSTEP”
� Function blocks: “Siemens\Step7\S7LIBS/FMSTSV_L” or

“Siemens\Step7\S7LIBS/FM353_354”
� OP interface: “Siemens\Step7\EXAMPLES\FM354\zEn14_02_FM354_OP_EX” or

“Siemens\Step7\EXAMPLES\FM353\zEn13_02_FM353_OP_EX”
� User examples: “Siemens\Step7\EXAMPLES\zEn14_03_FM354_EX” or

“Siemens\Step7\EXAMPLES\zEn13_03_FM353_EX”
� MD DBs (for start-up): “Siemens\Step7\EXAMPLES\FM353\MD” (on FM 353 only)

Instructions on how to install the configuring package can also be found in Section 5.1 of the Manual.

Parameterizing the FM 354 or FM 353 module

If you have not yet created a project, proceed as follows:

Set up a new project in the SIMATIC Manager by selecting  File → New → Projects  and enter a proj-
ect name. Insert your project in the SIMATIC 300 Station by selecting  Insert → SIMATIC 300 Station
in the new project window.

Select the  SIMATIC 300 Station. Open the S7 hardware configuration screen by selecting menu com-
mands  Edit → Open Object.

Open the hardware catalog by selecting  Insert → Hardware Components  or  View → Catalog. Select
SIMATIC 300 → RACK-300 → Rail. Drag the rail into your hardware project.

By the same method, select the CPU and the FM 354 or FM 353 module with associated order num-
bers (MLFBs) from the hardware catalog and drag them to the appropriate location (location 2 for the
CPU, in the example: Location 4 for the FM 354 or FM 353).

Save and compile your hardware project by selecting commands  Station → Save and Compile.

Note: The configured CPU and FM 354 or FM 353 are now included in your project in the SIMATIC
Manager.

Select the FM 354 or FM 353 in your hardware project.

Select menu items  Edit → Object Properties  to call dialog “Properties − FM354 SERVO − (R0/S4)” or
“Properties − FM353 STEPPER − (R0/S4)”.

Click on button  Parameters...  to open the “Parameterize FM 354” or “Parameterize FM 353” inter-
face.

Select  OK  when the “Save Project?” query appears.
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FM 354

When you click on button  MD  in the main window, a new Machine Data Data Block (DB-MD) is
opened. The parameters of this DB-MD are set to defaults (“Machine Data” display).

These defaults will enable you to traverse an axis if your system configuration is as follows:
� Power section: SIMODRIVE 611-A
� Motor: 1FT5
� Encoder: Rotary incremental encoder with 2,500 increments/rev

If your system is configured differently, then you will need to parameterize the following machine data
to match your configuration:
� Controller data: MD26 “Zero speed range”
� Axis data: MD23 “Maximum velocity”
� Encoder data: MD11/12 “Distance per encoder revolution”

MD13 “Increments per encoder revolution”

FM 353

By loading the configuring package, you have installed directory “FM353\MD”. This directory contains
data blocks for machine data for starting up FM STEPDRIVE and the corresponding SIMOSTEP.
These DB-MDs are assigned machine data defaults which will enable you to traverse an axis.

Select menu commands  File → Import  to open the MD file (note file type!) for the appropriate motor
in directory “[STEP7 directory]\EXAMPLES\FM353\MD”.

e.g. si02_353.md for a SIMOSTEP 2 Nm motor.

Deactivate the setting  Controller Already Active  on the index card “Drive Interface” under MD37. Se-
lect setting  No Boost, No PWM Active  under “Phase Current Control of Drive” on index card “Drive
Data”.

If your system is configured differently, then you will need to parameterize the following machine data
to match your configuration:

Drive interface: MD11/12 “Distance per motor revolution”
MD13 “Steps per motor revolution”

Once you have parameterized the FM 354 or FM 353 to match your configuration, proceed as
follows:

Save the DB-MD by selecting  File → Save.

Close the “Machine Data” screen.

Click on button  Transfer Data to FM...  in the main display.

In the “Data Block Transfer” dialog, select machine data block “DB 1200” (FM 354) or “DB 1210” 
(FM 353) under “Data Block Offline”.

Click on button  Transfer to FM  to send the MD-DB to the FM 354 or FM 353.

Close the dialog.

Test: You have set up the necessary safety measures for moving an axis.

Open the start-up window by selecting  Test → Start-up  or by clicking on button  Start-up  in
the main window.

Set the operating mode to  Jog.

Select  Servo Enable  and  Drive Enable  (drive enable/axis enable). Enter an override of 50%.

Select button  R+.

You can now initiate a traversing motion by pressing the  spacer key.. Your motor will rotate (at
the setting for velocity level 1) while the spacer key is pressed and you can monitor the actual
position in the start-up display (dynamic response of axis in accordance with defaults).
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Should an error occur during the test, you can reset the test run by selecting buttons  Restart  or  Ack-
now  or  DIQ  in the start-up window.

You can read the error message with error number and error text by selecting menu items  Test →
Error Analysis  or clicking on button  Error Display  in the main window.

If you change any machine data, you must activate them by clicking on button  MD active  after they
have been loaded to the FM.

Note: For further start-up instructions, please refer to Section 7 of the Manual.

For further information about parameterizing the FM 354 or FM 353 module, please refer to Section 5
of the Manual.

Linking into user program using an example

When you loaded the configuring package, you also installed example project “zEn14_02_FM354_EX”
or “zEn13_02_FM353_EX”. Provided you have properly completed the steps described above, you
can use Example 1 (EXAMPLE1) from this project to move an axis of the FM 354 or FM 353.

Proceed as follows:

Close windows “Parameterize FM 354” or “Parameterize FM 353”, “Properties” and “S7 Hardware
Configuration”.

Enter  Yes  to system query “Save changes in SIMATIC 300(1)?”.

Open example project “zEn14_02_FM354_EX” or “zEn13_02_FM353_EX” in the SIMATIC Manager
by selecting  File → Open → Projects.

Select directory “EXAMPLES” in this example project. This directory contains:
� A “Symbols” file
� A “Blocks” directory

Select the “Symbols” file and copy it to your project under  SIMATIC 300 Station → CPUxxx → S7
Program.

Enter  Yes  to system query “... Do you want to replace the existing object and all its contents?”.

Open the “Blocks” directory in example project “zEn14_02_FM354_EX” or “zEn13_02_FM353_EX”
and copy all the blocks it contains into your project under  SIMATIC 300 Station → CPUxxx → S7 Pro-
gram → Blocks.

The following blocks are now stored in your project:
� FC 0 to FC 3 − technology functions
� FC 100 − basic example for setting the operating mode
� FC 101 to FC 103 − examples 1, 2, 3
� DB 1 − user data block (from UDT 1)
� DB 100 − example data block (DBEX)
� OB 1 − cycle OB
� OB 100 − restart OB
� OB 82 − diagnosis alarm OB
� UDT 1 − user-defined data type
� Variables table VAT1...3

Open “OB 100” with a double click.

The LAD\STL\CSF Editor is opened.

Enter LADDR:=256 (for example) for FC “POS_INIT” call parameter under Network 2 in OB 100.

Save OB 100 by selecting  File → Save.

Close the Editor.

Select  SIMATIC 300 Station → CPUxxx → S7 Program → Blocks  in the SIMATIC Manager. Load all
the S7 blocks (including system data) stored in this directory to your CPU (CPU in STOP state) by
selecting  Target System → Load.

Switch your CPU to the RUN-P state.
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After the CPU and FM 354 or FM 353 have powered up successfully, the following settings have been
preset by block OB 100:
� “Jog” mode with operating mode parameter BP = 1 (value of velocity level 1)
� Override 100%
� Servo enable set
� Velocity levels: 40 m/min (level 1) and 80 m/min (level 2)

You can monitor the status of the FM module in the main display or by selecting  Test → Start-up  in
the parameterization tool. You can open the parameterization tool screen by selecting  SIMATIC 300
Station → Edit → Open Object, double clicking on the FM 354 or FM 353 object and finally clicking on
button  Parameters  in the “Properties” dialog.

To be able to monitor or set the bits in DB 100 used in the user program, you must start the “View and
Control Variables” tool. To do this, select your project in the SIMATIC Manager and then select  
SIMATIC 300 Station → CPUxxx → S7 Program → Blocks. With a double click on the variables table
VAT1 in the “Blocks” directory, you open the “View and Control Variables” tool. Establish an online
connection via the menu  Target System →�Establish Connection to → CPU Configured (directly con-
nected CPU).

Enter the following bits in the column headed “Operand”:
� DBEX.EX1DIR_P (plus direction)
� DBEX.EX1.DIR_M (minus direction)
� DBEX.EX1.GO_P (plus travel)
� DBEX.EX1.GO_M (minus travel)

To start the axis (plus direction), enter “2#1” in the “Control Value” column in the line for bit
“DBEX.EX1.DIR_P” and activate the traverse motion by selecting  Variables → Activate Control Val-
ues.
To end the movement, change the value of bit “DBEX.EX1.DIR_P” from “2#1” to 2#0 and terminate
the motion by selecting menu commands  Variables → Activate Control Values.

To start the axis (minus direction), enter “2#1” in the “Control Value” column in the line for bit
“DBEX.EX1.DIR_M” and activate the traverse motion by selecting  Variables → Activate Control Val-
ues.
To end the movement, change the value of bit “DBEX.EX1.DIR_M” from “2#1” to 2#0 and terminate
the motion by selecting menu commands  Variables → Activate Control Values.

You can monitor the operands cyclically by selecting  Variables → View.

You can update the operands once for monitoring by selecting  Variables → Update Status Values.

For information about programming standard function blocks, please refer to Section 6 of the Manual.
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Further examples

The “zEn14_02_FM354_EX” or “zEn13_02_FM353_EX” project contains further helpful examples
which you can adapt to your application.

Note

You should activate functions alarm generation, alarm selection and all monitors in normal opera-
tion.

You can set the alarm generation function on index card “Basic Parameters” in dialog “Properties −
FM 354 SERVO − (R0/S4)” or “Properties − FM 353 STEPPER − (R0/S4)” (see also heading “Para-
meterizing the FM 354 or FM 353 module” or Section 5.2 in Manual).

The monitoring functions, e.g. MD20 hardware monitor, MD21/22 software limit switches, etc. are acti-
vated by means of parameter settings.

Make sure that the data are transferred to the FM 354 or FM 353 and the CPU again afterwards.

Diagnostics

Input errors, wiring mistakes or conflicting parameter settings may cause errors which are displayed
by group error LED “SF” on the FM 354 or FM 353.

For a description of how to localize and remedy errors and messages of this type, please refer to Sec-
tion 11 of the Manual.
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